Table Names Dropdown Does Not Populate

Mar 9, 2010 at 4:53 PM

I pass my assembly to the app, but the dropdown doesn't populate.  I looked at the code and I am wondering why you're looking for properties that are a subclass of DataServiceQuery.  Wouldn't you be looking for IQueryable<TableServiceEntity>?  This is in Synchroniser.cs.

Coordinator
May 13, 2010 at 1:30 AM

Sorry for the very long delay, I had forgotten to enable notifications in CodePlex.

Yes this issue has been raised before, I'm yet to fix it. Personally I prefer to use DataServiceQuery in my context as it allows easy access to query options such as continuation tokens. DataServiceQuery inherits from IQueryable.

But I understand that many other people just use IQueryable, so I need to add support for that too.

I presume you just changed to code to get it working for you?

Anthony.

May 13, 2010 at 3:38 AM
Yeah. I've moved on from azure for the time being. Thanks.

Sent from my iPhone

Please excuse its brevity and/or typographical errors.

On May 12, 2010, at 9:30 PM, "antscode" <notifications@codeplex.com> wrote:

From: antscode

Sorry for the very long delay, I had forgotten to enable notifications in CodePlex.

Yes this issue has been raised before, I'm yet to fix it. Personally I prefer to use DataServiceQuery in my context as it allows easy access to query options such as continuation tokens. DataServiceQuery inherits from IQueryable.

But I understand that many other people just use IQueryable, so I need to add support for that too.

I presume you just changed to code to get it working for you?

Anthony.